Vulnerabilidad en WordPress 5.0.0 permite ejecutar código de manera remota | WeLiveSecurity

Vulnerabilidad en WordPress 5.0.0 permite ejecutar código de manera remota

Investigadores publicaron detalles de una vulnerabilidad en WordPress aún activa y que estuvo sin ser descubierta más de seis años

Investigadores publicaron detalles de una vulnerabilidad en WordPress aún activa y que estuvo sin ser descubierta más de seis años

La vulnerabilidad, que combina Path Traversal y Local File Inclusion, permite a un atacante que obtiene acceso a una cuenta con privilegios de autor en WordPress ejecutar de manera arbitraria código PHP en el servidor, pudiendo tomar control del sitio.

La vulnerabilidad, que es difícil de explotar, ya que las cuentas por defecto para un nuevo usuario en WordPress no son de autor, dejó de ser explotable en las versiones 5.0.1 y 4.9.9 del gestor de contenidos luego de que se lanzara un parche para reparar otra vulnerabilidad. Sin embargo, los investigadores de RIPS Technologies descubrieron que actualmente esta vulnerabilidad de Path Traversal aún es explotable en cualquier sitio de WordPress que tenga instalado un plugin que manipule de manera incorrecta entradas Post Meta. Y según explican los investigadores en una publicación reciente, millones de plugins activos cometen este error.

Una cuenta de autor comprometida o falsa tiene la capacidad de modificar entradas asociadas a una imagen y establecerles valores arbitrarios permitiendo explotar la vulnerabilidad de Path Traversal, que en combinación con el fallo de Local File Inclusion en el directorio “theme”, permite a un actor malicioso ejecutar código de manera arbitraria en el servidor atacado.

En un video publicado por el investigador a cargo se aprecia cómo es posible ejecutar el ataque en solo unos segundos y de esta manera obtener control total de un sitio WordPress vulnerable.

Luego de haber sido notificado acerca del fallo, WordPress comenzó a trabajar en un parche para reparar el error, aunque de momento el fallo aún puede ser explotado. Igualmente, recomendamos a aquellos que aún no lo han hecho actualizar a la versión 5.0.3 que es la última disponible.

Discusión