Vulnerabilidad en Adobe Reader permite descargar malware

Días atrás Adobe lanzó la actualización 8.1.2 de su producto más conocido: el lector de archivos PDF, Adobe Reader. En ese momento, Adobe no dió detalles de las 26 correcciones realizadas e incluso al momento de escribir esto, la actualización en castellano (sí la de inglés) aún no se encuentra disponible para descargar automáticamente y debe actualizarse a la nueva versión 8.1.2 manualmente desde el sitio de Adobe.

Luego de un pequeño análisis de la actualización realizada por Adobe, se puede llegar a la conclusión que estas vulnerabilidades son críticas porque permiten la ejecución de código Javascript en el sistema del usuario, permitiendo que, por ejemplo, se pueda descargar y ejecutar malware en el mismo.

Esto es lo que ha estado sucediendo desde hace unos días y los Adobe Reader no actualizados han estado siendo aprovechados para instalar diversos tipos de malware como KillAV o Zonebac o gusanos de la vieja familia Bagle (profundamente analizado por ESET).

Sin importar el malware descargado y que se sabe que puede cambiar en cualquier momento, lo importante es:

  • Para los productos antivirus, detectar la explotación de la vulnerabilidad para cortar la cadena de infección desde el primer momento. Es por ello que ESET NOD32 detecta este exploit como PDF/Exploit.Pidief.A. Gracias a esta detección, no importa el código dañino que se intente descargar debido a que dicha descarga nunca sucederá.
  • Para el usuario, es fundamental actualizar su Adobe Reader a la versión mencionada o bien utilizar un producto alternativo para la lectura de archivos PDF.

Actualización 27/02/2008: acabamos de publicar un video educativo sobre el funcionamiento de esta vulnerabilidad y la forma de evitar ser infectado.

Cristian

Autor , ESET

Síguenos